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Introduction
The Warddeken Land Management Mayh 
Project runs the largest species-monitoring 
network established by an Aboriginal 
organisation or Indigenous Protected Area (IPA) 
in Australia. Co-designed by Bininj leaders 
and Elders to detect long-term changes in key 
species, the project operates across 21 clan 
estates and involves Landowners from across 
the IPA.

To safeguard the health of the 
Kuwarddewardde mayh (Stone Country 
animals), Nawarddeken (people of the Stone 
Country) combine customary practices with 
modern land management techniques and 
technologies. One such technology is the 
use of CPW Warehouse, customised with a 
bilingual database, which enables Rangers 
to identify animals in images using language 
names. Additionally, Warddeken integrates CPW 

Warehouse with the programs MegaDetector 
and EcoAssist to identify and remove images 
without animals. Searching empty images is a 
lengthy and tedious task and time saved since 
implementing these programs has empowered 
daluk (women) rangers to engage in a broader 
range of land management activities, increasing 
confidence and technological capacity in 
the workplace.

This tutorial will guide you through the set-
up and basic functions of a CPW Warehouse 
database, integrated with MegaDetector, 
EcoAssist and a bilingual database. CPW 
Warehouse is a versatile program, with good 
capacity to accommodate the unique needs 
of your project as you set it up. If required, 
the resources at the end of this document will 
guide you through advanced troubleshooting 
and functionality.

How to use EcoAssist to set up a 
CPW database
CPW Warehouse is a customisable program 
designed to facilitate archiving, identifying, 
summarising and analysing photo data 
collected from remote wildlife cameras.

EcoAssist is a no-code user interface (after 
installation) that separates images with 

animals from empty images. EcoAssist does 
this using MegaDetector’s artificial intelligence 
framework.

MegaDetector is an ‘object detection program’, 
which identifies animals, people and vehicles in 
images. It also identifies empty images.
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Folder setup
Create a folder for your camera trap images and add the below 
sub folders.

•	Upload your SD cards into the Raw Images folder. Each SD card 
should have its own folder, named after the camera number.

•	If there are multiple folders on the SD card, copy the first 
folder’s images across. Then, select all images in the second 
folder and rename them so that the number in the name is 
10,000. If there is a third folder, select all and change the 
number to 20,000 and so on. Then copy those images to the 
folder. When there are multiple folders containing over 10,000 
images on a single SD card, this preserves the order that the 
images were taken, so that we can easily find raw images 
if required.

•	Create an additional folder for your images on C Drive. 
EcoAssist will process images directly from this folder. Copy the 
subfolders containing your raw images to this folder.

C Drive has less disk space 
than other drives, so if 
you have a large number 
of images, you may need 
to repeat the EcoAssist 
processing step multiple 
times with smaller batches of 
images, deleting a batch from 
C Drive as you complete it, 
then copying the next batch of 
folders across.
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MegaDetector and 
EcoAssist installation
•	Install MegaDetector and EcoAssist from github.com/

PetervanLunteren/EcoAssist#windows-installation.

•	Download packages Git and Anaconda directly to your C Drive 
from Gitforwindows.org and anaconda.com.

•	Right-click to open EcoAssist as an administrator on the 
installation download. A command prompt box will open.

•	Specify where Anaconda3 and Git have been downloaded to in 
your C Drive.

•	Move the EcoAssist shortcut from Downloads to your 
preferred area.

Once entered the prompt will 
download everything you 
need to run MegaDetector. 
This can take up to 40 minutes 
depending on internet 
connection and computer 
processing capacity.

https://github.com/PetervanLunteren/EcoAssist#windows-installation
https://github.com/PetervanLunteren/EcoAssist#windows-installation
https://Gitforwindows.org
https://anaconda.com
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Using EcoAssist to 
process images
•	Open EcoAssist. The program will ask permission to make 

changes to your computer, click yes. It will initially open a 
command prompt box, but will convert to a user interface a 
few seconds later.

•	Browse to the folder where your images are stored on C Drive. 
Select the boxes in the image below and set the checkpoint 
frequency to 500.

•	Click Deploy model. A progress box will appear.

•	Once image processing is complete, an image recognition JSON 
file will be added to your image folder in C Drive.

If you have poor internet 
connectivity or do not have 
access to a high-powered 
computer, it may be beneficial 
to set checkpoint frequency to 
50, so that progress is saved 
every 50 images, rather than 
every 500.

Depending on the power 
of your PC and number 
of images that need to 
be processed, it may take 
anywhere from minutes to 
weeks to complete this step. 
For example, we used a lower-
powered PC to process 20,000 
images and it took 24 hours 
to process. In contrast, we 
processed millions of images 
on a high-powered PC, which 
took around a week and half 
of 24/7 processing.

You may need to change the 
settings on the PC so that it 
doesn’t go to sleep if left to 
process overnight.
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Post-processing to prepare 
images for CPW
Use the post-processing function to automatically group images 
into separate entities (animals, people, vehicle, empty) with their 
own folders.

•	Browse to the location where the post-processed images will 
be saved (MD_Images). Select Copy in Separation options.

•	Once post-processing is complete, open the MD_Images 
folder, select your desired entity and the camera you are 
interested in. The animal folders can now be uploaded to CPW. 
The image recognition JSON file can be moved from C Drive 
into the JSON folder you created earlier.

There is an option to draw 
bounding boxes around 
the animals, to expedite 
the identification process. 
Leave this box unchecked if 
you would like to encourage 
thorough searching of images.
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Preparing a CPW database
•	Download a copy of CPW (Version: 4.3.0.6) and the user 

manual below.

Colorado Parks & Wildlife - Software: CPW Photo Warehouse 
(state.co.us).

•	When making a new CPW database, copy the download into the 
desired location and re-name it, rather than writing over the 
top of the download.

•	Open CPW. The CPW switchboard should appear.

Security warnings

If a security warning or a message indicating that VBA code is 
blocked appears, you will see a screen similar to below. To fix 
it, you will need to save the folder containing the database as a 
Trusted Location. Depending on which version of Windows you 
are operating, try one of the below two options.

The user manual contains 
detailed instructions and 
troubleshooting which is 
not covered in this general 
set-up document.

This image and option one text from CPW User Manual, Newkirk, E. S. 2016

https://state.co.us
https://state.co.us
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Option one

First, open Access (CPW uses Microsoft Access to store and make 
data connections) from the Start menu. You should see a welcome 
screen with options to build a new database, open an existing one, 
get content from Microsoft Online, etc. Click the Office Button. 
Now click Access Options → Trust Center → Trust Center Settings 
→ Trusted Locations. Check to see if the folder where you want 
to save the database is included in the list. If not, you can add it 
by clicking the Add New Location… button. Note that subfolders 
are not necessarily included, so a database saved in a folder within 
My Documents may not work even if My Documents is a trusted 
location. If you want subfolders of a particular location to be 
trusted make sure to check the box for that option.

When the above steps are complete, restart the application and it 
should display the above switchboard.

Option two

Click File → Options (in the bottom left corner of the screen) → 
Trust Centre → Trust Centre Settings.
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Then click Trusted locations → Add new location.

Browse to the folder where the database is stored. Check 
Subfolders of this location are also trusted if required, then 
click OK.
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Importing data

You can set up a database using the options on the switchboard 
or by accessing the database tables directly. If you have a small 
number of cameras, using the switchboard and entering data 
manually may be feasible. If there are many cameras, data can 
be imported directly to CPW tables, saving time and reducing the 
likelihood of error. Data can also be cut-and-pasted from Excel or 
typed directly into tables.

You will need three items before you can upload images:

1	 A unique name and number for the study area.

2	 A spreadsheet or text file with camera numbers and locations 
(with coordinates).

3	 A list of species you expect to see, (including Latin names) and 
any additional details you might want to add (e.g. sex, collared, 
language names). You can also add the species as they are 
identified through the ‘photo ID form’.

Optional add-ins (recommended):

4	 Species groups, such as mammal, bird, reptile, amphibian; 
native or introduced, or events such as fire or flood.

5	 A list of names of observers.

In this tutorial, we have used text files. Create an Excel 
spreadsheet for your data and save it as a tab-delimited text 
file to match. However, importing other file types is a very 
similar process.

•	To import directly into tables, click the X to close the 
switchboard form and the Access database will appear. You 
can re-open the switchboard anytime by double clicking 
Switchboard in the Forms section on the left of the page.

In order for any file to upload 
to CPW correctly, the column 
headings on your spreadsheet 
must match the column 
headings in the CPW table 
exactly. You can add, rename 
and re-order columns in CPW 
prior to uploading files.

There is an example of 
Warddeken’s species 
spreadsheet included at 
the end of this section. This 
spreadsheet is where we 
combine common, scientific 
and language names to form 
the bilingual database. Using 
this as a template for your 
species list, the end user will 
be able to tag images using 
language or common names.

In this tutorial, we will import 
data directly to tables.
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•	Enter the Study Area by clicking on the Camera Data Tables 
drop-down menu and selecting StudyAreas.

•	Select External Data → New Data Source → From File → 
Text File.
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The Data Wizard will appear. Browse to your file, then select 
Append a copy of the records to the table → Select the relevant 
CPW table from the drop-down menu and click OK.

Select Delimited, then click Next.
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Select Tab as the delimiter and check First Row Contains Field 
Names if your text file contains column headings. A preview of 
your table will appear as you select options. Click Next.

Double check that the correct table has been selected and 
click Finish.
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The table should match your text file or spreadsheet.

•	To enter camera locations, repeat the above import process, 
ensuring the columns in your text file match the columns 
in CPW exactly. You can add, rename or re-arrange columns 
to suit your requirements. The below picture shows the 
unmodified camera locations table and the second image 
shows additional columns we have added to suit our operations.

Repeat the import steps for species list, species groups and 
observers. These three tables can be found under the Other 
Tables drop-down menu.
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Bilingual database

This is Warddeken’s species list. We have added an additional 
column for language names (KunwokName) and also added 
language names to the ShortName column. If we do not have a 
language name, we use the common name. Importing the species 
list enables users to tag images in language or common names.

Importing images

Open the switchboard (double click Switchboard in the Forms 
section on the left of the page), and select Add or Edit Visits. 
Under the Select Location drop-down menu, all of your cameras 
should appear as location names, prefixed with a study area 
acronym. Select a location and click the Add New Visit button.



16 WARDDEKEN LAND MANAGEMENT HOW TO SET UP A CPW DATABASE ED 1 3/24

Select Set, Check or Pull from the visit types (set is when you 
set the camera up, pull is when you retrieved it and check is if 
you checked the camera in between setting and pulling) and 
add the date that these occurred. Select Next Visit to enter 
additional visits.

Once you have entered a set and a pull date, a Load Photos 
option will appear. Select this.
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Browse to the folder containing animal images: MD Images → 
animal and select the camera that corresponds with the selected 
location and click OK.

Check Copy Image Files and browse to the destination folder, in 
this case it is the Copied Images folder you made earlier. Once 
inside the Copied Images folder, create a new folder for the 
copied images. You can name this folder after the camera number 
or the location code (below) for this camera.
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Rename the image files to prefix with location ID and rename with 
image number, date and time. Click Import Photos.

This screen will display if a folder of images has uploaded correctly.

When EcoAssist returns 
processed images, they will 
no longer be in chronological 
order. Renaming the images 
retains the order.
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When you click OK, you will see that images from that camera 
have replaced the Load Photos button in the camera visits form.

•	Repeat this process for all cameras.

•	As you add visits and import images, the visits table will 
automatically populate the set and pull dates (under visit type ID 
and visit date). You will also notice that CPW has automatically 
detected the active start and end dates for each camera.

If the camera’s date and time were incorrect during the 
deployment, you can adjust this by selecting Add or Edit Visits 
on Switchboard → Select The Location. Click the Edit button on 
the Pull line → Adjust Photo Date / Time. From here you can add 
or subtract days from the first image on the camera and CPW will 
automatically adjust the remaining images and update the active 
start and end dates in the visits table.
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Image ID

To identify images, select ID Photos on Switchboard → select 
your name from the drop-down menu (if you added observers 
during setup).

Select a location and you can now use the photo ID form to 
ID images.

Create modules

CPW can produce ‘modules’ which can be emailed, shared via 
sharing services or copied to external hard drives if you have 
rangers who would like to ID animals from an external PC or 
laptop. A single module contains a database and images for a 
single camera. Rangers can ID animals, but will not have access to 
any other CPW functions. These modules can then be uploaded to 
CPW when complete.

In order for the modules to upload correctly, the module name 
must match the location code (below image) exactly. The modules 
can be renamed once on the hard drive or receiving PC. Only the 
module database needs to be uploaded to CPW, the photo folder 
is not required after image ID is complete.You can close the program at 

any time and your work will 
save automatically.

See page 23 of the CPW User 
Guide for details on creating 
and uploading modules.
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Resources
Warddeken Land Management – How to  
set up a camera trap for biodiversity 
monitoring projects 
https://healthycountryai.org/files/
WarddekenCameraTrapSetup.pdf

Warddeken Land Management – How to set 
up a Timelapse database using EcoAssist 
https://healthycountryai.org/files/
WarddekenTimelapseDBSetup.pdf

EcoAssist 
addaxdatascience.com/ecoassist/

EcoAssist GitHub repo 
github.com/PetervanLunteren/
EcoAssist?tab=readme-ov-file#windows-
installation

How do I get started with Megadetector?  
wildlabs.net/event/how-do-i-get-started-
megadetector

CPW Photo Warehouse 
cpw.state.co.us/learn/Pages/
ResearchMammalsSoftware.aspx
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