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Introduction
The Warddeken Land Management Mayh 
Project runs the largest species-monitoring 
network established by an Aboriginal 
organisation or Indigenous Protected Area (IPA) 
in Australia. Co-designed by Bininj leaders 
and Elders to detect long-term changes in key 
species, the project operates across 21 clan 
estates and involves Landowners from across 
the IPA.

To safeguard the health of the 
Kuwarddewardde mayh (Stone Country 
animals), Nawarddeken (people of the Stone 
Country) combine customary practices with 
modern land management techniques and 
technologies. One such technology is the 
use of the programs MegaDetector and 

EcoAssist to identify and remove images 
without animals, prior to uploading images 
to image ID programs such as Timelapse or 
CPW Warehouse. Searching empty images is a 
lengthy and tedious task and time saved since 
implementing these programs has empowered 
daluk (women) rangers to engage in a broader 
range of land management activities, increasing 
confidence and technological capacity in 
the workplace.

This tutorial will guide you through the set-
up of a basic Timelapse database, integrated 
with MegaDetector and EcoAssist. If required, 
the resources at the end of this document will 
guide you through advanced troubleshooting 
and functionality.

How to use EcoAssist to set up a 
Timelapse database
Timelapse consists of two programs, 
Timelapse and Timelapse Template Editor. 
Timelapse enables users to view and analyse 
subsets of images and categorise them 
according to species, location, time of day, 
overexposed or other categories. Timelapse 
Template Editor enables users to set up 
the Timelapse interface with the required 
categories and species.

EcoAssist is a no-code user interface (after 
installation) that separates images with 
animals from empty images. EcoAssist does 
this using MegaDetector’s artificial intelligence 
framework.

MegaDetector is an ‘object detection program’, 
which identifies animals, people and vehicles in 
images. It also identifies empty images.
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Folder setup
Create a folder for raw images from your camera traps.

Example:

Warddeken Monitoring 2023

LAC01

LAC01_C1

•	Upload your SD cards into the Raw Images folder. Each SD card 
should have it’s own folder, named after the camera number.

•	If there are multiple folders on the SD card, copy the first 
folder’s images across. Then, select all images in the second 
folder and rename them so that the number in the name is 
10,000. If there is a third folder, select all and change the 
number to 20,000 and so on. Then copy those images to the 
folder. When there are multiple folders containing over 10,000 
images on a single SD card, this preserves the order that the 
images were taken, so that we can easily find raw images 
if required.

•	Create an additional folder for your images on the C Drive. 
EcoAssist will process images directly from this folder. Copy the 
subfolders containing your Raw Images folder to this folder.

Consider how you’d like to 
set up your file structure. If 
it is a one-off project, you 
might create a folder for that 
project and create a raw 
images folder within it. If it is 
an ongoing project, you might 
create a file for that project, 
then add subfolders for each 
year or time period that image 
collection will occur and then 
add a raw images folder for 
each time period. If you move 
folders at a later date, you will 
need to relink Timelapse to 
the new folder locations.

C Drive has less disk space 
than other drives, so if 
you have a large number 
of images, you may need 
to repeat the EcoAssist 
processing step multiple 
times with smaller batches of 
images, deleting a batch of 
images from C Drive as you 
complete it, then copying the 
next batch of folders across.

Root Folder. Store your 
Timelapse template and 
Timelapse project here.
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Timelapse installation
Download timelapse 2 from https://saul.cpsc.ucalgary.ca/
timelapse/pmwiki.php?n=Main.Download2.

•	Extract the Zip File and place it in your C Drive

•	Create a shortcut for Timelapse2 and 
Timelapse2TemplateEditor for easy access on your desktop.

Create a Timelapse 
Template
•	Open Timelapse Template Editor. To create a Timelapse 

Template, you first need to save it to the same root folder 
as the images on your C Drive. When you save, it will 
automatically generate a Backups folder in this location. The 
Backups folder contains backups of your database file, never 
delete this folder.

•	Add a line with a count for number of animals in each image, 
a line with a note for comments, then a line with a choice, 
adding the species you are expecting to see to the box that 
appears when you click Define List.

Here we can also define our species list which can be a 
combination of common names and language names specific to 
your Country. In Timelapse we recommend you add all the names 
you want to use at the start.

•	Add species as Fixed Choice.

•	Add individuals as Count.

•	Add good photo/empty/ID as Flag.

•	Add metadata you might want to add as Comment.

Don’t move anything within 
the Timelapse folder as it uses 
all these files to function.

As you add lines, a preview of 
how the Timelapse interface 
will display appears at the 
bottom of the template. From 
this template, you can rename 
the data labels by typing over 
them, re-order the columns 
at the bottom of the template, 
or toggle column visibility for 
the user.

https://saul.cpsc.ucalgary.ca/timelapse/pmwiki.php?n=Main.Download2
https://saul.cpsc.ucalgary.ca/timelapse/pmwiki.php?n=Main.Download2
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•	Open Timelapse 2, click File → Load Template and navigate to 
the template location on your C Drive.

We’ll come back to Timelapse later…

If you have set up your 
folders correctly, Timelapse 
should automatically load 
your images.
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MegaDetector and 
EcoAssist installation
•	Install MegaDetector and EcoAssist from github.com/

PetervanLunteren/EcoAssist#windows-installation.

•	Download packages Git and Anaconda directly to your C Drive 
from Gitforwindows.org and anaconda.com.

•	Right-click to open EcoAssist as an administrator on the 
installation download. A command prompt box will open.

•	Specify where Anaconda3 and Git have been downloaded to in 
your C Drive.

•	Move the EcoAssist shortcut from Downloads to your 
preferred area.

Once entered the prompt will 
download everything you 
need to run MegaDetector. 
This can take up to 40 minutes 
depending on internet 
connection and computer 
processing capacity.

https://github.com/PetervanLunteren/EcoAssist#windows-installation
https://github.com/PetervanLunteren/EcoAssist#windows-installation
https://Gitforwindows.org
https://anaconda.com
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Using EcoAssist to process 
images
•	Open EcoAssist. The program will ask permission to make 

changes to your computer, click yes. It will initially open a 
command prompt box, but will convert to a user interface a 
few seconds later.

•	Browse to the folder where your images are stored on the 
C Drive. Select the boxes in the image below and set the 
checkpoint frequency to 500.

•	Click Deploy model. A progress box will appear.

If you have poor internet 
connectivity or do not have 
access to a high-powered 
computer, it may be beneficial 
to set checkpoint frequency to 
50, so that progress is saved 
every 50 images, rather than 
every 500.

Depending on the power 
of your PC and number 
of images that need to 
be processed, it may take 
anywhere from minutes to 
weeks to complete this step. 
For example, we used a lower-
powered PC to process 20,000 
images and it took 24 hours 
to process. In contrast, we 
processed millions of images 
on a high-powered PC, which 
took around a week and half 
of 24/7 processing.

You may need to change the 
settings on the PC so that it 
doesn’t go to sleep if left to 
process overnight.
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•	Once image processing is complete, the below files will have 
been added to your image folder in C Drive.

Backups is a folder that is automatically generated by Timelapse 
and contains backups of your database file. Never delete it.

Timelapse Data (.ddb) is a database file created and updated 
by Timelapse as you load and analyse your image set. The file 
stores all the data that you entered, as well as other information 
required by Timelapse. Never delete it.

JSON File is your AI file from EcoAssist. Never delete it.

Clearing C drive and relinking the database to 
the raw images folder

Use the below steps to move and link files to the Raw Images 
folder in preparation for deleting files from the C drive.

•	Move all Timelapse files and the image recognition JSON file to 
the Raw Images folder.

As the Timelapse template and image pathways are linked to the 
C Drive images folder, you will need to update image file pathways 
to reflect their new location in the Raw Images folder.

•	Open Timelapse → Load Timelapse Template and use the 
Locate button to navigate to the Raw Images folder where the 
template is now stored and click Use New Location.

Raw Images is your working 
folder and these files must 
be in the same root folder as 
the images for the program 
to function.
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•	To link image folders to the Raw Images folders, go to the Edit 
tab → Try to find any missing folders.

•	The below screen will appear, use the Locate button to 
navigate to the corresponding folder in the Raw Images folder. 
Repeat this for all folders, then click Use new locations.

Once this is complete and 
you have checked that your 
Timelaspe 2 database is 
functioning correctly, you can 
delete the image folders on 
your C Drive and prepare to 
copy across and process the 
next batch of images.
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Preparing a Timelapse 2 
database
Load the Timelapse Template
•	Go to the File tab → Load template and browse to your 

Timelapse Template in your image folder on C Drive, then 
click OK. Your images should load automatically.

Load image recognition file
•	Go to the Recognitions tab → Import image recognition data 

for this image set and browse to your image recognition file 
which is now in the Raw Images folder.
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Populate metadata

Camera-trap images contain metadata: data describing time, 
temperature, type of camera, moonphase etc. Some of this can be 
very useful for science!

•	Select Edit from the menu.

•	Choose ExifTool as the inspection tool.

•	Click the Data fields from the right-side column that you 
would like to include.

•	Click the Populate button to load the metadata for 
those fields.

We suggest:

•	Temperature

•	Camera Model Name

•	Moonphase

•	Sequence

•	Camera Label.
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Creating quickpaste entries for tagging images

Make one quickpaste for each species you commonly record.

•	Select Edit → Show Quickpaste Window, then click on Species 
and deselect the others. Select the species name you want 
to use.

Select images of animals

•	Go to the Select tab → Custom selection, then click the Use 
recognition box.

•	Use the Recognised entity drop down box to view images of 
animals, people, vehicles, all or empty.
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Now, only images containing 
animals from the camera 
you’ve specified will be 
displayed on the screen. 
These images are ready for 
identification.

•	Click the RelativePath folder and select the camera you would 
like to view from the dropdown box. Click OK.
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Double checking 
your work!
Consider this a bit like quality control, the person who set up 
the camera database should look at each camera site Timelapse 
database and make sure IDs are all good, all the fields are filled in 
and look for any errors or images that have not been tagged as 
either empty or an animal.

If you have used a language name that can mean more than 
one species (e.g. mulbbu for all small rodents/dasuryids) it is 
important to change this to a unique name (e.g. common name 
like Arnhem rock rat or common rock rat) before exporting 
the data. This means you don’t need to go back and check the 
image again.

Checking images and individual site-based 
Timelapse databases

The Select and Custom Selection tools are your friends here! 
Look at how the number of files that match your query changes:

•	Select

•	Custom Selection

•	Select what photos you want to find (good photos, species 
names to review, empty).

Checklist:

•	All images either have a SpeciesID or are tagged as ‘empty’

•	Check unknown animal

•	Review language names that occur for multiple species.

You can also use the same function to filter your images and 
export them into folders that you can share with Landowners.

From the File menu select Export (copy) all the images and 
video in the current selection.
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Exporting data
•	Once image ID is complete, data can be exported. Go to the 

File tab → Export data in the current selection → OK.

If you would like to export data for all images, you will need 
to remove your custom selections. Go to the Selections tab → 
Custom selection → Reset to all images (bottom, left hand side 
of the screen).

Exporting images
•	If you would like to export your selected animal or other 

images for other purposes go to File → Export (copy) all 
images in the current selection.
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Select a folder for animal images to be copied to. Timelapse will 
automatically generate a subfolder in this location if you select 
Put in Subfolder and provide a name → Export.
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Appendix: Species names
To aid with creating species name lists and 
reviewing, you may want to create a database 
of known species names.

As long as all species have been tagged with a 
name that identifies back to the common name 
these can be renamed later (e.g. kornobolo, 
warradjankal) in R or Excel.

Common nameCommon name Scientific nameScientific name TaxaTaxa Other namesOther names

Agassiz’s Glassfish Ambassis agassizii Fish djenj

Agile Wallaby Petrogale brachyotis Mammal kornobolo,warradjangkal (male), 
merlbbe (female), 
nakornborrh (juvenile male), 
nakurdakurda (large male)

Alana’s Menetia Menetia alanae Reptile burndjingh, loklok

Antilopine Wallaroo Osphranter antilopinus Mammal kalabah (male), karndayh (female), 
karndakidj (male), kolobarr (male)

Arafura Fantail Rhipidura (Howeavis) dryas Bird

Arafura Filesnake Acrochordus arafurae Reptile kedjebe, bekka, nawandak

Arnhem Leaf-Nosed Bat Hipposideros inornatus Mammal warlung (small), mulumbibi (small), 
buma buma (big), kuluban (big)

Arnhem Long-Eared Bat Nyctophilus arnhemensis Mammal warlung (small), mulumbibi (small), 
buma buma (big), kuluban (big)

Arnhem Rock-Rat Zyzomys maini Mammal mullbu, djirrkinj, bob, 
kidjikidjidaykdayk, birng

Arnhemland 
Watercourse Dtella

Gehyra pamela Reptile belerrk, moloborndok

Australasian Darter Anhinga melanogaster 
novaehollandiae

Bird kardabaybay, djingarrarr, 
mandjangarli, kunbad karrulubun

Australasian Figbird Sphecotheres vieilloti Bird

Australasian Harrier Circus approximans Bird

Australasian Pipit Anthus novaesselandiae Bird
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Common nameCommon name Scientific nameScientific name TaxaTaxa Other namesOther names

Australian Bustard Ardeotis australis Bird benok, benuk

Australian Hobby Falco (Falco) longipennis Bird

Australian Little Grebe Tachybaptus novaehollandiae Bird

Australian Owlet-
Nightjar

Aegotheles crisatus Bird lablab, djik

Australian Pelican Pelecanus conspicillatus Bird makkakkurr, werne

Australian Pratincole Stiltia isabella Bird

Australian White Ibis Threskiornis moluccus Bird

Australian White-
Winged Triller

 Lalage (Lalage) tricolor Bird

Azure Kingfisher Ceyx azureus Bird djirrihdiddid
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Resources
Warddeken guides

Warddeken Land Management – How to  
set up a camera trap for biodiversity 
monitoring projects 
https://healthycountryai.org/files/
WarddekenCameraTrapSetup.pdf

Warddeken Land Management – How to set 
up a CPW database using EcoAssist 
https://healthycountryai.org/files/
WarddekenCPWDBSetup.pdf

Timelapse

Timelapse website 
saul.cpsc.ucalgary.ca/timelapse/

Timelapse guides

Quick Start Guide 
saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/
TimelapseQuickStartGuide.pdf

Reference Guide 
saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/
TimelapseReferenceGuide.pdf

Database Guide 
saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/
TimelapseDatabaseGuide.pdf

EcoAssist and Megadetector 
information

EcoAssist 
addaxdatascience.com/ecoassist/

EcoAssist GitHub repo 
github.com/PetervanLunteren/
EcoAssist?tab=readme-ov-file#windows-
installation

How do I get started with Megadetector?  
wildlabs.net/event/how-do-i-get-started-
megadetector

Video tutorial

Quick Start Guide  
https://saul.cpsc.ucalgary.ca/timelapse/uploads/
Videos/Video-TimelapseQuickStartGuide.mp4

https://healthycountryai.org/files/WarddekenCameraTrapSetup.pdf
https://healthycountryai.org/files/WarddekenCameraTrapSetup.pdf
https://healthycountryai.org/files/WarddekenCameraTrapSetup.pdf
https://healthycountryai.org/files/WarddekenCPWDBSetup.pdf
https://healthycountryai.org/files/WarddekenCPWDBSetup.pdf
https://saul.cpsc.ucalgary.ca/timelapse/
https://saul.cpsc.ucalgary.ca/timelapse/
https://saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/TimelapseQuickStartGuide.pdf
https://saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/TimelapseQuickStartGuide.pdf
https://saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/TimelapseQuickStartGuide.pdf
https://saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/TimelapseReferenceGuide.pdf
https://saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/TimelapseReferenceGuide.pdf
https://saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/TimelapseReferenceGuide.pdf
https://saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/TimelapseDatabaseGuide.pdf
https://saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/TimelapseDatabaseGuide.pdf
https://saul.cpsc.ucalgary.ca/timelapse/uploads/Guides/TimelapseDatabaseGuide.pdf
https://addaxdatascience.com/ecoassist/
https://addaxdatascience.com/ecoassist/
https://github.com/PetervanLunteren/EcoAssist?tab=readme-ov-file#windows-installation
https://github.com/PetervanLunteren/EcoAssist?tab=readme-ov-file#windows-installation
https://github.com/PetervanLunteren/EcoAssist?tab=readme-ov-file#windows-installation
https://github.com/PetervanLunteren/EcoAssist?tab=readme-ov-file#windows-installation
https://www.wildlabs.net/event/how-do-i-get-started-megadetector
https://www.wildlabs.net/event/how-do-i-get-started-megadetector
https://www.wildlabs.net/event/how-do-i-get-started-megadetector
https://saul.cpsc.ucalgary.ca/timelapse/uploads/Videos/Video-TimelapseQuickStartGuide.mp4
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